Ruby 跨入效能開掛新時代,陸續結束老版本支援

類別: IT
標籤: ruby
Ruby

Ruby 開發團隊近日在官網宣佈,所有關於 Ruby 2.2 系列的支援已結束:

在 2017 年 3 月 28 日釋出 Ruby 2.2.7 之後,Ruby 2.2 的支援進入了安全維護期。現已過去一年,該階段已結束。Ruby 新版的 bug 和安全修復不再移植到 2.2 系列,也不再發布 2.2 系列的版本補丁。建議儘快升級至 Ruby 2.5 或 2.4 版本。

Ruby 在6月份釋出了 2.6 全新系列的第二個預覽版本,該版本由於引入期待已久的新特性 JIT 而被認為對於 Ruby 有著不同尋常的意義。在此前的 Ruby 25 週年的慶祝會上,創始人 Matz 也曾透露,Ruby 下一步將主要圍繞“提高生產力”的核心目標進行發展,Ruby 3 將主打快速、分散式(可伸縮)和精明(分析),最終實現 3 倍提速。Ruby 3 計劃在 2020 年釋出,而 Ruby 2.6 則是為推進其 3 倍提速目標實現而邁出的第一步。

Ruby 版本當前支援狀態

Ruby 2.5 系列

目前處於常規維護階段。必要時,會移植 bug 修復,釋出新版。如果發現嚴重安全問題,會發布緊急修復。

Ruby 2.4 系列

目前處於常規維護階段。必要時,會移植 bug 修復,釋出新版。如果發現嚴重安全問題,會發布緊急修復。

Ruby 2.3 系列

目前處於安全維護階段。除了安全修復之外,不再把 bug 修復移植到 2.3 系列。如果發現嚴重安全問題,會發布緊急修復。對 Ruby 2.3 系列的支援計劃到 2019 年 3 月底結束。

Ruby 跨入效能開掛新時代,陸續結束老版本支援原文請看這裡